summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCaleb Ristvedt <caleb.ristvedt@cune.org>2018-05-27 23:20:54 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-01 15:35:54 +0200
commitbf5bf5778cb7c3a2475c6acd707abc925b1819aa (patch)
tree34f209fea10a40e45468ecbc4ad15c46905df114 /Makefile.am
parent285cc75c3160421005ba0181490de4b290755b63 (diff)
downloadgnu-guix-bf5bf5778cb7c3a2475c6acd707abc925b1819aa.tar
gnu-guix-bf5bf5778cb7c3a2475c6acd707abc925b1819aa.tar.gz
Add (guix store deduplication).
* guix/store/database.scm (register-path): Add #:deduplicate? and call 'deduplicate' when it's true. (counting-wrapper-port, nar-sha256): Move to... * guix/store/deduplication.scm: ... here. New file. * tests/store-deduplication.scm: New file. * Makefile.am (STORE_MODULES): Add deduplication.scm. (SCM_TESTS) [HAVE_GUILE_SQLITE3]: Add store-deduplication.scm. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d81fce5585..474575c9f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -259,7 +259,8 @@ endif BUILD_DAEMON_OFFLOAD
# Scheme implementation of the build daemon and related functionality.
STORE_MODULES = \
- guix/store/database.scm
+ guix/store/database.scm \
+ guix/store/deduplication.scm
if HAVE_GUILE_SQLITE3
MODULES += $(STORE_MODULES)
@@ -392,7 +393,8 @@ endif
if HAVE_GUILE_SQLITE3
SCM_TESTS += \
- tests/store-database.scm
+ tests/store-database.scm \
+ tests/store-deduplication.scm
endif