summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-27 15:23:44 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-28 23:51:16 +0200
commit4f024ef3181c5235ff11789e8c8f62722f974787 (patch)
tree5c2e96065dc44a2a465d3cc8469fd6815fd0c7ef /Makefile.am
parent894fc4e9f5cf5184be54321c1ba5c8e51a6380d7 (diff)
downloadgnu-guix-4f024ef3181c5235ff11789e8c8f62722f974787.tar
gnu-guix-4f024ef3181c5235ff11789e8c8f62722f974787.tar.gz
build: Remove code to download the Guile bootstrap tarball.
* build-aux/download.scm: Remove. * Makefile.am (EXTRA_DIST): Remove it. (check-system): Remove dependency on $(BOOTSTRAP_GUILE_TARBALLS). * gnu/local.mk (nodist_bootstrap_x86_64_linux_DATA) (nodist_bootstrap_i686_linux_DATA, nodist_bootstrap_armhf_linux_DATA) (nodist_bootstrap_aarch64_linux_DATA, nodist_bootstrap_mips64el_linux_DATA) (BOOTSTRAP_GUILE_TARBALLS, DISTCLEANFILES, DOWNLOAD_FILE) (%D%/packages/bootstrap/x86_64-linux/guile-2.0.9.tar.xz) (%D%/packages/bootstrap/i686-linux/guile-2.0.9.tar.xz) (%D%/packages/bootstrap/armhf-linux/guile-2.0.11.tar.xz) (%D%/packages/bootstrap/aarch64-linux/guile-2.0.14.tar.xz) (%D%/packages/bootstrap/mips64el-linux/guile-2.0.9.tar.xz): Remove. * build-aux/test-env.in: Add "guix download" invocation when gnu/packages/bootstrap/guile* exists.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ba4ccba78..661f9d6453 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -388,7 +388,7 @@ check-local:
endif !CAN_RUN_TESTS
-check-system: $(GOBJECTS) $(BOOTSTRAP_GUILE_TARBALLS)
+check-system: $(GOBJECTS)
$(AM_V_at)$(top_builddir)/pre-inst-env \
$(GUILE) --no-auto-compile \
-e '(@@ (run-system-tests) run-system-tests)' \
@@ -418,7 +418,6 @@ EXTRA_DIST = \
build-aux/hydra/guix.scm \
build-aux/check-available-binaries.scm \
build-aux/check-final-inputs-self-contained.scm \
- build-aux/download.scm \
build-aux/generate-authors.scm \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \