summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-26 22:17:40 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-08 17:48:25 +0200
commit2cfc8d69644af6c53fed9128425e8ff70ad4509f (patch)
treeb06a31fcef43a9a60ec372853488d06749aee270 /Makefile.am
parentf0527ce3a40e07d5f56b4b18c7eec91dbd016e88 (diff)
downloadgnu-guix-2cfc8d69644af6c53fed9128425e8ff70ad4509f.tar
gnu-guix-2cfc8d69644af6c53fed9128425e8ff70ad4509f.tar.gz
build: Add 'as-derivation' target.
* build-aux/compile-as-derivation.scm: New file. * Makefile.am (as-derivation): New target. (EXTRA_DIST): Add compile-as-derivation.scm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4edd05d72..908115e524 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -470,6 +470,7 @@ EXTRA_DIST = \
build-aux/hydra/guix-modular.scm \
build-aux/check-available-binaries.scm \
build-aux/check-final-inputs-self-contained.scm \
+ build-aux/compile-as-derivation.scm \
build-aux/generate-authors.scm \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
@@ -535,6 +536,13 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
install-data-hook: set-bootstrap-executable-permissions
touch "$(DESTDIR)$(guileobjectdir)/guix/config.go"
+# Assuming Guix is already installed and the daemon is up and running, this
+# rule builds from $(srcdir), creating and building derivations.
+as-derivation:
+ $(AM_V_at)echo "Building Guix in Guix..." ; \
+ $(GUILE) --no-auto-compile \
+ "$(top_srcdir)/build-aux/compile-as-derivation.scm" \
+ "$(abs_top_srcdir)"
SUBDIRS = po/guix po/packages
BUILT_SOURCES =
@@ -763,7 +771,7 @@ cuirass-jobs.scm: $(GOBJECTS)
.PHONY: gen-ChangeLog gen-AUTHORS gen-tarball-version
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained
-.PHONY: clean-go make-go
+.PHONY: clean-go make-go as-derivation
.PHONY: update-guix-package update-NEWS release
## -------------- ##