summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:41 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-30 01:30:57 +0000
commitf0f177bac837cb6dbb431e2dd204ed0271fb3b11 (patch)
treeedaad78e7e95e6f8772b5cc2fd34505ab3f6cfe8
parent1484dece16725ecc4ddd5c5ff60c8c0d4b5d52de (diff)
downloadgnu-guix-f0f177bac837cb6dbb431e2dd204ed0271fb3b11.tar
gnu-guix-f0f177bac837cb6dbb431e2dd204ed0271fb3b11.tar.gz
gnu: Add ruby-omniauth.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9e284b64a9..191afe7b08 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1101,6 +1101,31 @@ complexity.")
(home-page "http://github.com/intridea/oauth2")
(license license:expat)))
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1p16h1rp8by05k8gfw17xjhgwp60dk8qmj1xalv1n23kmxfsxb1x"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A generalized Rack framework for multiple-provider authentication.")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider authentication.")
+ (home-page
+ "https://github.com/omniauth/omniauth")
+ (license license:expat)))
+
(define-public ruby-open4
(package
(name "ruby-open4")