summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:00:03 +0100
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-30 09:02:04 +0000
commite6a6146865d83984cc838078290f9e58df994e53 (patch)
treeb54a25585f8b804051b9572c905037616ee110a9
parent2b2ec9bbdde6b37449026eec01619d5ee159cbae (diff)
downloadgnu-guix-e6a6146865d83984cc838078290f9e58df994e53.tar
gnu-guix-e6a6146865d83984cc838078290f9e58df994e53.tar.gz
gnu: Add ruby-web-console.
-rw-r--r--gnu/packages/rails.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index 8db3768907..5c0ae40186 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -543,3 +543,46 @@ favoring convention over configuration.")
(home-page
"http://rubygems.org/gems/jquery-rails")
(license license:expat)))
+
+(define-public ruby-web-console
+ (package
+ (name "ruby-web-console")
+ (version "3.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Download from GitHub as test files are not provided in the gem.
+ (uri (string-append "https://github.com/rails/web-console/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gmymwvgwqjv4gmg2vb0abm6flwax9sg73wmh6yb7m818pn2lz3n"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Do not test to prevent dependency cycle with rails.
+ ;; (arguments
+ ;; `(#:phases
+ ;; (modify-phases %standard-phases
+ ;; (add-before 'check 'setenv
+ ;; (lambda _
+ ;; (setenv "RUBYLIB" "lib")
+ ;; ;; (substitute* "Rakefile"
+ ;; ;; (("require 'web_console") ; This is not required for
+ ;; ;; ; travis, so hmm.
+ ;; ;; "require 'pathname'; require 'uri'; require 'web_console"))
+ ;; #t)))))
+ ;; (native-inputs
+ ;; `(("bundler" ,bundler)))
+ (propagated-inputs
+ `(("ruby-actionview" ,ruby-actionview)
+ ("ruby-activemodel" ,ruby-activemodel)
+ ("ruby-debug-inspector" ,ruby-debug-inspector)
+ ("ruby-railties" ,ruby-railties)))
+ (synopsis
+ "A debugging tool for your Ruby on Rails applications.")
+ (description
+ "This package provides a debugging tool for your Ruby on Rails applications.")
+ (home-page
+ "https://github.com/rails/web-console")
+ (license license:expat)))