summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-15 15:46:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 17:27:34 +0100
commit81bed4e92b75c06605938371f5365d7283a7a9fd (patch)
treeba7da8f34157524a59f0689a4204e5f0564a6daf
parentd0446c4b55d8611f66d3590f14e161c40e1c40c9 (diff)
downloadgnu-guix-81bed4e92b75c06605938371f5365d7283a7a9fd.tar
gnu-guix-81bed4e92b75c06605938371f5365d7283a7a9fd.tar.gz
gnu: Add python-astor.
* gnu/packages/python-xyz.scm (python-astor): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fee94aa537..d6f994a3f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14693,6 +14693,26 @@ RFC 8265 and RFC 8266.")
of Python libraries for building Python applications.")
(license license:asl2.0)))
+(define-public python-astor
+ (package
+ (name "python-astor")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "astor" version))
+ (sha256
+ (base32
+ "13gv6f2xz9i564byp21gcpc0l3w4cs23k1wbcam8kky2ls3hvhwm"))))
+ (build-system python-build-system)
+ ;; FIXME: There are two errors and two test failures.
+ (arguments `(#:tests? #f))
+ (home-page "https://github.com/berkerpeksag/astor")
+ (synopsis "Read/rewrite/write Python ASTs")
+ (description "Astor is designed to allow easy manipulation of Python
+source via the AST.")
+ (license license:bsd-3)))
+
(define-public python-wikidata
(package
(name "python-wikidata")