summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 16:41:10 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-29 22:56:12 +0000
commit660989493beeeea77a42adfb0bebb8714c926e53 (patch)
tree1e730fcca900cb97101d37b96424434d8913988b
parent010d86a0caf72fc7f056f75a8e6b6c9c77aa3a0d (diff)
downloadgnu-guix-660989493beeeea77a42adfb0bebb8714c926e53.tar
gnu-guix-660989493beeeea77a42adfb0bebb8714c926e53.tar.gz
gnu: Add ruby-hashdiff.
Required for ruby-webmock. * gnu/packages/ruby.scm (ruby-hashdiff): New variable.
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f38af898ff..c409fed834 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1231,6 +1231,38 @@ failure.")
(home-page "https://github.com/thekompanee/fuubar")
(license license:expat)))
+(define-public ruby-hashdiff
+ (package
+ (name "ruby-hashdiff")
+ (version "0.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hashdiff" version))
+ (sha256
+ (base32
+ "19ykg5pax8798nh1yv71adkx0zzs7gn2rxjj86v7nsw0jba5lask"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Run tests directly via rspec to avoid Rake issue:
+ ;; NoMethodError: undefined method `last_comment'
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec-2)))
+ (synopsis "HashDiff computes the smallest difference between two hashes")
+ (description
+ "HashDiff is a Ruby library to compute the smallest difference between
+two hashes.")
+ (home-page "https://github.com/liufengyun/hashdiff")
+ (license license:expat)))
+
(define-public ruby-shindo
(package
(name "ruby-shindo")