summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-29 17:18:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-29 17:18:23 +0100
commit631337063ed07419a22ca1eaf2c5fa3042e89344 (patch)
tree7a048e950cf1a8e2fbbe415b2a83eb03dbff0065
parent1d4c2dabefdc5e957ed74a58066f8faa8e0fb70e (diff)
downloadgnu-guix-631337063ed07419a22ca1eaf2c5fa3042e89344.tar
gnu-guix-631337063ed07419a22ca1eaf2c5fa3042e89344.tar.gz
gnu: Add texlive-latex-beamer.
* gnu/packages/tex.scm (texlive-latex-beamer): New variable.
-rw-r--r--gnu/packages/tex.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5a577a5e9b..2a135080b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5811,3 +5811,68 @@ for use with LaTeX is available in @code{freenfss}, part of
supports advanced interactive documents. See the ConTeXt garden for a wealth
of support information.")
(license license:gpl2+)))
+
+(define-public texlive-latex-beamer
+ (package
+ (name "texlive-latex-beamer")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/beamer"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "09y3qwbj0nckshvg9afgwcv9v3zdif1d7bnpzrggsa1fbr80mgk2"))))
+ (build-system trivial-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/beamer"))
+ (docs (string-append (assoc-ref %outputs "doc")
+ "/share/texmf-dist/doc/latex/beamer/")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+
+ (mkdir-p docs)
+ (copy-recursively (assoc-ref %build-inputs "docs") docs)
+ #t))))
+ (propagated-inputs
+ `(("texlive-latex-hyperref" ,texlive-latex-hyperref)
+ ("texlive-latex-oberdiek" ,texlive-latex-oberdiek)
+ ("texlive-latex-etoolbox" ,texlive-latex-etoolbox)
+ ("texlive-latex-pgf" ,texlive-latex-pgf)))
+ (native-inputs
+ `(("docs"
+ ,(origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/doc/latex/beamer"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "102b18b9nw9dicqqgjwx0srh1mav8vh9wdvwayn741niza9hac23"))))))
+ (home-page "https://www.ctan.org/pkg/beamer")
+ (synopsis "LaTeX class for producing presentations and slides")
+ (description "The beamer LaTeX class can be used for producing slides.
+The class works in both PostScript and direct PDF output modes, using the
+@code{pgf} graphics system for visual effects. Content is created in the
+@code{frame} environment, and each frame can be made up of a number of slides
+using a simple notation for specifying material to appear on each slide within
+a frame. Short versions of title, authors, institute can also be specified as
+optional parameters. Whole frame graphics are supported by plain frames. The
+class supports @code{figure} and @code{table} environments, transparency
+effects, varying slide transitions and animations.")
+ ;; Code is dual licensed under GPLv2+ or LPPL1.3c+; documentation is
+ ;; dual-licensed under either FDLv1.3+ or LPPL1.3c+.
+ (license (list license:lppl1.3c+ license:gpl2+ license:fdl1.3+))))