summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-10-23 20:36:50 -0400
committerMark H Weaver <mhw@netris.org>2014-10-26 02:55:37 -0400
commit6178ae9cb7e7803684cab3267e8c0cb498a027c7 (patch)
treea6792f60494131e6a0d318793d3d9635346ba8ee
parentf9e687b51aafaa160b3c361c801ec5823dbef2f0 (diff)
downloadgnu-guix-6178ae9cb7e7803684cab3267e8c0cb498a027c7.tar
gnu-guix-6178ae9cb7e7803684cab3267e8c0cb498a027c7.tar.gz
gnu: make: Update to 4.1.
* gnu/packages/base.scm (make): Update to 4.1. Adapt 'default_shell' substitution to new code. * gnu/packages/commencement.scm (gnu-make-boot0): Remove code that manually removed guile.c from list of things to build.
-rw-r--r--gnu/packages/base.scm8
-rw-r--r--gnu/packages/commencement.scm4
2 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fe2f0f07e8..a3b9095572 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -273,14 +273,14 @@ functionality beyond that which is outlined in the POSIX standard.")
(define-public gnu-make
(package
(name "make")
- (version "4.0")
+ (version "4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/make/make-" version
".tar.bz2"))
(sha256
(base32
- "1nyvn8mknw0mf7727lprva3lisl1y0n03lvar342rrpdmz3qc1p6"))
+ "19gwwhik3wdwn0r42b7xcihkbxvjl9r2bdal8nifc3k5i4rn3iqb"))
(patches (list (search-patch "make-impure-dirs.patch")))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config", pkg-config))) ; to detect Guile
@@ -293,8 +293,8 @@ functionality beyond that which is outlined in the POSIX standard.")
;; Change the default shell from /bin/sh.
(let ((bash (assoc-ref inputs "bash")))
(substitute* "job.c"
- (("default_shell\\[\\] =.*$")
- (format #f "default_shell[] = \"~a/bin/bash\";\n"
+ (("default_shell =.*$")
+ (format #f "default_shell = \"~a/bin/bash\";\n"
bash)))))
%standard-phases)))
(synopsis "Remake files automatically")
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 92ac090722..20831de997 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -74,10 +74,6 @@
((#:phases phases)
`(alist-replace
'build (lambda _
- ;; Don't attempt to build 'guile.c' since we don't
- ;; have Guile here.
- (substitute* "build.sh"
- (("guile\\.\\$\\{OBJEXT\\}") ""))
(zero? (system* "./build.sh")))
(alist-replace
'install (lambda* (#:key outputs #:allow-other-keys)