summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 09:46:41 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-29 22:56:12 +0000
commit5d0e2d803c6e54baa07e205d121174aa35859db1 (patch)
tree684f91e0ac4c496f1f27c83c19bb27e15fdae2aa
parent7ca012931f1429cb32a8b44739cb8a6866142a0d (diff)
downloadgnu-guix-5d0e2d803c6e54baa07e205d121174aa35859db1.tar
gnu-guix-5d0e2d803c6e54baa07e205d121174aa35859db1.tar.gz
gnu: ruby-gherkin: Update to 5.1.0.
Don't upgrade all the way to version 6, as version 5 is needed for Cucumber 3. * gnu/packages/ruby.scm (ruby-gherkin): Update to 5.1.0. [description]: Use @file{ }.
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ddaf9e1bc3..e507c816c8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3775,14 +3775,14 @@ Ruby classes.")
(define-public ruby-gherkin
(package
(name "ruby-gherkin")
- (version "4.1.3")
+ (version "5.1.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "gherkin" version))
(sha256
(base32
- "1d18r8mf2qyd9jbq9xxvca8adyysdzvwdy8v9c2s5hrd6p02kg79"))))
+ "1cgcdchwwdm10rsk44frjwqd4ihprhxjbm799nscqy2q1raqfj5s"))))
(build-system ruby-build-system)
(native-inputs
`(("bundler" ,bundler)))
@@ -3790,9 +3790,9 @@ Ruby classes.")
'(#:tests? #f)) ; needs simplecov, among others
(synopsis "Gherkin parser for Ruby")
(description "Gherkin is a parser and compiler for the Gherkin language.
-It is intended be used by all Cucumber implementations to parse '.feature'
-files.")
- (home-page "https://github.com/cucumber/gherkin3")
+It is intended be used by all Cucumber implementations to parse
+@file{.feature} files.")
+ (home-page "https://github.com/cucumber-attic/gherkin")
(license license:expat)))
(define-public ruby-cucumber-core