summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-28 16:41:37 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-29 22:56:13 +0000
commit298293d6cc5f497bfccfb09f562c4922e3fe68d6 (patch)
treef607b42050e860cf4d4de46ebf45884fe608d708
parent280769373b4e171e538837ce13f367fd2a643436 (diff)
downloadgnu-guix-298293d6cc5f497bfccfb09f562c4922e3fe68d6.tar
gnu-guix-298293d6cc5f497bfccfb09f562c4922e3fe68d6.tar.gz
gnu: Add ruby-rails.
* gnu/packages/rails.scm (ruby-rails): New variable.
-rw-r--r--gnu/packages/rails.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index a45dca65d1..2d7ccceff7 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -412,3 +412,56 @@ application bootup, plugins, generators, and Rake tasks.")
(home-page
"https://github.com/rails/sprockets-rails")
(license license:expat)))
+
+(define-public ruby-rails
+ (package
+ (name "ruby-rails")
+ (version "5.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rails" version))
+ (sha256
+ (base32
+ "1m9cszds68dsiycciiayd3c9g90s2yzn1izkr3gpgqkfw6dmvzyr"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; This gem acts as glue between the gems that actually make up
+ ;; Rails. The important thing to check is that the gemspec matches up
+ ;; with the Guix packages and Rubygems can successfully activate the
+ ;; Rails gem.
+ ;;
+ ;; The following check phase tests this.
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key tests? outputs #:allow-other-keys)
+ (setenv "GEM_PATH"
+ (string-append
+ (getenv "GEM_PATH")
+ ":"
+ (assoc-ref outputs "out") "/lib/ruby/vendor_ruby"))
+ (when tests?
+ (invoke "ruby" "-e" "gem 'rails'"))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-activesupport" ,ruby-activesupport)
+ ("ruby-actionpack" ,ruby-actionpack)
+ ("ruby-actionview" ,ruby-actionview)
+ ("ruby-activemodel" ,ruby-activemodel)
+ ("ruby-activerecord" ,ruby-activerecord)
+ ("ruby-actionmailer" ,ruby-actionmailer)
+ ("ruby-activejob" ,ruby-activejob)
+ ("ruby-actioncable" ,ruby-actioncable)
+ ("ruby-activestorage" ,ruby-activestorage)
+ ("ruby-railties" ,ruby-railties)
+ ("bundler" ,bundler)
+ ("ruby-sprockets-rails" ,ruby-sprockets-rails)))
+ (synopsis "Full-stack web framework optimized for programmer happiness")
+ (description
+ "Ruby on Rails is a full-stack web framework optimized for programmer
+happiness and sustainable productivity. It encourages beautiful code by
+favoring convention over configuration.")
+ (home-page "https://rubyonrails.org/")
+ (license license:expat)))