summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-15 15:48:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 17:27:34 +0100
commit2884aac071a19233713bab274a6908ae1d9e834e (patch)
treef7b79d1446b13e2169eff63f481ece8b539b048b
parent79869f806432522d4d9b60f0af1294e8808514b6 (diff)
downloadgnu-guix-2884aac071a19233713bab274a6908ae1d9e834e.tar
gnu-guix-2884aac071a19233713bab274a6908ae1d9e834e.tar.gz
gnu: Add python-gast.
* gnu/packages/python-xyz.scm (python-gast): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38a5087e9b..b9a40585bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14736,6 +14736,28 @@ factored out version of @code{unparse} found in the Python source
distribution.")
(license license:bsd-3)))
+(define-public python-gast
+ (package
+ (name "python-gast")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gast" version))
+ (sha256
+ (base32
+ "0c296xm1vz9x4w4inmdl0k8mnc0i9arw94si2i7pglpc461r0s3h"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-astunparse" ,python-astunparse)))
+ (home-page "https://pypi.org/project/gast/")
+ (synopsis "Generic Python AST that abstracts the underlying Python version")
+ (description
+ "GAST provides a compatibility layer between the AST of various Python
+versions, as produced by @code{ast.parse} from the standard @code{ast}
+module.")
+ (license license:bsd-3)))
+
(define-public python-wikidata
(package
(name "python-wikidata")