summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 16:41:55 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-29 22:56:12 +0000
commit08959bc569f982cf9e29cbb7ce6f2c9a8193457f (patch)
tree203a6296a3e01b17f37c154d0c6a98ac43a2853a
parent0f3368f44bef2c66cac017d9e992b63f5117001f (diff)
downloadgnu-guix-08959bc569f982cf9e29cbb7ce6f2c9a8193457f.tar
gnu-guix-08959bc569f982cf9e29cbb7ce6f2c9a8193457f.tar.gz
gnu: Add ruby-webmock.
Required by ruby-rest-client. Also at version ~> 2, so don't package 3 just yet. * gnu/packages/ruby.scm (ruby-webmock): New variable.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8b72210ac3..fc2c75e134 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4787,6 +4787,32 @@ support to both Ruby and JRuby. It uses @code{unf_ext} on CRuby and
(home-page "https://github.com/knu/ruby-unf")
(license license:bsd-2)))
+(define-public ruby-webmock-2
+ (package
+ (name "ruby-webmock")
+ (version "2.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "webmock" version))
+ (sha256
+ (base32
+ "04hkcqsmbfnp8g237pisnc834vpgildklicbjbyikqg0bg1rwcy5"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)
+ ("ruby-crack" ,ruby-crack)
+ ("ruby-hashdiff" ,ruby-hashdiff)))
+ (synopsis "Allows stubbing and setting expectations on HTTP requests")
+ (description
+ "WebMock allows stubbing HTTP requests and setting expectations on HTTP
+requests. This is useful when testing software.")
+ (home-page "https://github.com/bblimke/webmock")
+ (license license:expat)))
+
(define-public ruby-domain-name
(package
(name "ruby-domain-name")