summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 13:30:23 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-29 22:56:12 +0000
commit010d86a0caf72fc7f056f75a8e6b6c9c77aa3a0d (patch)
treeaf38f29940e8c545c8b2cc32c7fe5344522c3aeb
parent5efde317534e81b94eb31a6fccd2dc531bfeb0eb (diff)
downloadgnu-guix-010d86a0caf72fc7f056f75a8e6b6c9c77aa3a0d.tar
gnu-guix-010d86a0caf72fc7f056f75a8e6b6c9c77aa3a0d.tar.gz
gnu: Add ruby-racc.
Required for ruby-ast and ruby-parser. * gnu/packages/ruby.scm (ruby-racc): New variable.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fc543332f9..f38af898ff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3657,6 +3657,32 @@ differences (added or removed nodes) between two XML/HTML documents.")
(home-page "https://github.com/postmodern/nokogiri-diff")
(license license:expat))))
+(define-public ruby-racc
+ (package
+ (name "ruby-racc")
+ (version "1.4.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "racc" version))
+ (sha256
+ (base32
+ "00yhs2ag7yy5v83mqvkbnhk9bvsh6mx3808k53n61ddzx446v1zl"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "LALR(1) parser generator for Ruby")
+ (description
+ "Racc is a LALR(1) parser generator. It is written in Ruby itself, and
+generates Ruby program.")
+ (home-page "http://i.loveruby.net/en/projects/racc/")
+ (license (list
+ ;; Generally licensed under the LGPL2.1, and some files also
+ ;; available under the same license as Ruby.
+ license:lgpl2.1
+ license:ruby))))
+
(define-public ruby-rack
(package
(name "ruby-rack")