summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-02-16 00:18:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-02-16 00:32:16 +0100
commitf821b10190f3177195131aca5591eabecd838a34 (patch)
tree6bb49eb212c1ab78f602ba8acb8e3e2ab32b7c69
parent270cdbef26b345a68817031cca2ef112e292c2cd (diff)
downloadgnu-guix-f821b10190f3177195131aca5591eabecd838a34.tar
gnu-guix-f821b10190f3177195131aca5591eabecd838a34.tar.gz
gnu: pugixml: Update to 1.8.1.
* gnu/packages/xml.scm (pugixml): Update to 1.8.1. [arguments]: Remove ‘chdir’ phase and allow #:out-of-source building. Add comment about the lack of tests.
-rw-r--r--gnu/packages/xml.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 884efdcdf7..b91471690f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -741,7 +741,7 @@ the form of functions.")
(define-public pugixml
(package
(name "pugixml")
- (version "1.7")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
@@ -749,17 +749,10 @@ the form of functions.")
version "/pugixml-" version ".tar.gz"))
(sha256
(base32
- "1jpml475kbhs1aqwa48g2cbfxlrb9qp115m2j9yryxhxyr30vqgv"))))
+ "0fcgggry5x5bn0zhb09ij9hb0p45nb0sv0d9fw3cm1cf62hp9n80"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f
- #:out-of-source? #f
- #:phases (modify-phases %standard-phases
- (add-before
- 'configure 'chdir
- (lambda _
- (chdir "scripts")
- #t)))))
+ `(#:tests? #f)) ; no tests
(home-page "http://pugixml.org")
(synopsis "Light-weight, simple and fast XML parser for C++ with XPath support")
(description