summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-14 18:38:55 +0000
committerAlex Kost <alezost@gmail.com>2017-02-16 12:45:27 +0300
commite967dd9cf42d2cca48786067f17a42bedd031e71 (patch)
tree05b2f536bde5b860fce967a041d7b2dc07b97c7d
parent7f86a97cee8bc620c38160b4dc5c4e1f81ed685e (diff)
downloadgnu-guix-e967dd9cf42d2cca48786067f17a42bedd031e71.tar
gnu-guix-e967dd9cf42d2cca48786067f17a42bedd031e71.tar.gz
gnu: Add emacs-pretty-mode.
* gnu/packages/emacs.scm (emacs-pretty-mode): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 49799f2825..04c7a08011 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3790,3 +3790,23 @@ customizable by the user.")
Additionally it can display the number of unread emails in the
mode-line.")
(license license:gpl3+)))
+
+(define-public emacs-pretty-mode
+ (package
+ (name "emacs-pretty-mode")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/akatov/pretty-mode/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fan7m4vnqs8kpg7r54kx3g7faadkpkf9kzarfv8n57kq8w157pl"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/akatov/pretty-mode")
+ (synopsis "Redisplay parts of the buffer as Unicode symbols")
+ (description
+ "Emacs minor mode for redisplaying parts of the buffer as pretty symbols.")
+ (license license:gpl3+)))