summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:15:44 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-02-15 20:10:47 +0100
commite6515b55ea18e764b2c2f7f1823ad488640d75bc (patch)
treef135829a29e46aac1f8c0880c152679b24be7ed2
parent505394d1fd5c1d37402556327a872941f2f05b75 (diff)
downloadgnu-guix-e6515b55ea18e764b2c2f7f1823ad488640d75bc.tar
gnu-guix-e6515b55ea18e764b2c2f7f1823ad488640d75bc.tar.gz
gnu: Add ocaml-ppx-type-conv.
* gnu/packages/ocaml.scm (ocaml-ppx-type-conv): New variable.
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8a700097c9..d5d5bc6d1d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2186,3 +2186,27 @@ programs. It allows the definition of simple macros and file inclusion. Cpp oi
(description "Ppx_deriving provides common infrastructure for generating
code based on type definitions, and a set of useful plugins for common tasks.")
(license license:expat)))
+
+(define-public ocaml-ppx-type-conv
+ (package
+ (name "ocaml-ppx-type-conv")
+ (version "113.33.03")
+ (source
+ (janestreet-origin "ppx_type_conv" version
+ "1sp602ads2f250nv4d4rgw54d14k7flyhb4w8ff084f657hhmxv2"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-deriving" ,ocaml-ppx-deriving)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("result" ,ocaml-result)
+ ("ppx-core" ,ocaml-ppx-core)
+ ("ppx-driver" ,ocaml-ppx-driver)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_type_conv/")
+ (synopsis "Support Library for type-driven code generators")
+ (description "The type_conv library factors out functionality needed by
+different preprocessors that generate code from type specifications.")
+ (license license:asl2.0)))