summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 16:30:46 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-02-15 20:10:33 +0100
commitc333995063614038bc217536ac39ad35f57b3ed7 (patch)
tree89ad74d3ec9cfecb7d568198781a303497c08704
parent6bdf77a2a165743a126964190b59f92873e8664b (diff)
downloadgnu-guix-c333995063614038bc217536ac39ad35f57b3ed7.tar
gnu-guix-c333995063614038bc217536ac39ad35f57b3ed7.tar.gz
gnu: Add ocaml-ppx-core.
* gnu/packages/ocaml.scm (ocaml-ppx-core): New variable.
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8e3deb7a12..ca0674a6d2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2043,3 +2043,27 @@ storage of large amounts of data.")
record fields, to get and set record fields, iterate and fold over all fields
of a record and create new record values.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-core
+ (package
+ (name "ocaml-ppx-core")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_core" version
+ "0f69l4czhgssnhb5ds2j9dbqjyz8dp1y3i3x0i4h6pxnms20zbxa"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (inputs `(("ppx-tools" ,ocaml-ppx-tools)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_core/")
+ (synopsis "Standard library for ppx rewriters")
+ (description "Ppx_core is a standard library for OCaml AST transformers.
+It contains:
+@enumerate
+@item various auto-generated AST traversal using an open recursion scheme
+@item helpers for building AST fragments
+@item helpers for matching AST fragments
+@item a framework for dealing with attributes and extension points.
+@end enumerate")
+ (license license:asl2.0)))