summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-02-17 18:50:35 +0100
committerJohn Darrington <jmd@gnu.org>2017-02-17 18:52:24 +0100
commit1f45f18abe487be85c290227256690a3f32f7874 (patch)
treeb0a8dc3f713bc29a27ed4d525a585a9a7d227559
parent193abc823287096fa9e97f3010af4e36fd58b863 (diff)
downloadgnu-guix-1f45f18abe487be85c290227256690a3f32f7874.tar
gnu-guix-1f45f18abe487be85c290227256690a3f32f7874.tar.gz
installer: Aris: update synopis and description.
* gnu/packages/maths.scm (aris): Use the synopsis and description from the web page instead of the README file.
-rw-r--r--gnu/packages/maths.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 029a241cb7..18536c43ee 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -95,24 +95,26 @@
(define-public aris
(package
- (name "aris")
- (version "2.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/" name "/" name "-" version ".tar.gz"))
- (sha256 (base32
- "1hlvpzrh7hzzf533diyfiabzskddi8zx92av9hwkjw3l46z7qv01"))))
- (build-system gnu-build-system)
- (inputs `(("gtk+" ,gtk+)
- ("libxml2" ,libxml2)))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (synopsis "Logical proof program")
- (description
- "Aris is a logical proof program, and supports propositional and predicate
-logic, Boolean algebra, and arithmetical logic in the form of abstract
-sequences (seqlog).")
- (license license:gpl3+)
- (home-page "http://www.gnu.org/software/aris/")))
+ (name "aris")
+ (version "2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/" name "/" name "-" version ".tar.gz"))
+ (sha256 (base32
+ "1q1887ryqdr9sn0522hc7p16kqwlxxyz5dkmma8ar2nxplhgll7q"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+)
+ ("libxml2" ,libxml2)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Natural deduction first-order logic interface")
+ (description "Aris is a program for performing logical proofs. It supports
+propositional and predicate logic, as well as Boolean algebra and
+arithmetical logic. In addition to its predefined inference and equivalence
+rules, Aris also supports references to older proofs. Its use of standard
+logical symbols and its natural deduction interface make it easy to use for
+beginners.")
+ (license license:gpl3+)
+ (home-page "http://www.gnu.org/software/aris/")))
(define-public c-graph
(package