summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:25:31 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:31 -0600
commit0527b43db4843d37106351ac35515a70eb39d727 (patch)
tree6d2f81491fc1bd3cd4951a9f1eb66bae2537d536
parent5a0096a35d0653c2c004a66543cf7615a0c5d398 (diff)
downloadgnu-guix-0527b43db4843d37106351ac35515a70eb39d727.tar
gnu-guix-0527b43db4843d37106351ac35515a70eb39d727.tar.gz
gnu: Add libcss.
* gnu/packages/web.scm (libcss): New variable.
-rw-r--r--gnu/packages/web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dc08942e0f..1a44029c0e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3849,6 +3849,34 @@ designed to store small strings and allow rapid comparison of them. It is
developed as part of the Netsurf project.")
(license l:expat)))
+(define-public libcss
+ (package
+ (name "libcss")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.netsurf-browser.org/libs/releases/"
+ name "-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0qp4p1q1dwgdra4pkrzd081zjzisxkgwx650ijx323j8bj725daf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("netsurf-buildsystem" ,netsurf-buildsystem)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (propagated-inputs ;needed for libcss.pc
+ `(("libparserutils" ,libparserutils)
+ ("libwapcaplet" ,libwapcaplet)))
+ (arguments netsurf-buildsystem-arguments)
+ (home-page "http://www.netsurf-browser.org/projects/libcss/")
+ (synopsis "CSS parser and selection library")
+ (description
+ "LibCSS is a CSS (Cascading Style Sheet) parser and selection engine,
+written in C. It is developed as part of the NetSurf project.")
+ (license l:expat)))
+
(define-public netsurf
(package
(name "netsurf")