summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-11-10 01:09:02 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-12 16:10:23 +0100
commite2fca4906e30c6bd585dfe7dd7dd32b01f15e0d6 (patch)
tree5e74b8dee9fe4c757d1e5872cf7c5e854e064076
parent998f9ac56df6c8cc2ca383c0309f394b262d7f6a (diff)
downloadgnu-guix-e2fca4906e30c6bd585dfe7dd7dd32b01f15e0d6.tar
gnu-guix-e2fca4906e30c6bd585dfe7dd7dd32b01f15e0d6.tar.gz
gnu: Add python-termstyle.
* gnu/packages/python.scm (python-termstyle): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 59aebf83f6..9b3fda1b50 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12163,3 +12163,20 @@ asynchronous messaging environments.")
(define-public python2-axolotl
(package-with-python2 python-axolotl))
+
+(define-public python-termstyle
+ (package
+ (name "python-termstyle")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "termstyle" version))
+ (sha256
+ (base32
+ "17wzkkcqy5zc0g68xlad3kcv66iw14d2pwqc0h9420gak0vbhx7g"))))
+ (build-system python-build-system)
+ (home-page "http://github.com/gfxmonk/termstyle")
+ (synopsis "Console text coloring for Python")
+ (description "This package provides console text coloring for Python.")
+ (license license:bsd-3)))