summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-10 14:25:06 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-10 14:26:04 +0100
commitc68e8591d8fa948d83bc4914a0ed2f72ab368a9a (patch)
tree9d189ebed161ec20a132c058689e37dfd6a07067
parentad5a7d49c3e63045199c20a1988199ba52be8d70 (diff)
downloadgnu-guix-c68e8591d8fa948d83bc4914a0ed2f72ab368a9a.tar
gnu-guix-c68e8591d8fa948d83bc4914a0ed2f72ab368a9a.tar.gz
gnu: Add python2-pypdf.
* gnu/packages/pdf.scm (python2-pypdf): New variable.
-rw-r--r--gnu/packages/pdf.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d064aaa3e9..6c3d0fe89d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -833,3 +833,25 @@ manage or manipulate PDFs.")
(define-public python2-pypdf2
(package-with-python2 python-pypdf2))
+
+(define-public python2-pypdf
+ (package
+ (name "python2-pypdf")
+ (version "1.13")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyPdf" version))
+ (sha256
+ (base32
+ "0fqfvamir7k41w84c73rghzkiv891gdr17q5iz4hgbf6r71y9v9s"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:python ,python-2))
+ (home-page "http://pybrary.net/pyPdf/")
+ (synopsis "Pure Python PDF toolkit")
+ (description "PyPDF2 is a pure Python PDF toolkit.
+
+Note: This module isn't maintained anymore. For new projects please use
+python-pypdf2 instead.")
+ (license license:bsd-3)))