summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-10-15 15:03:52 +0200
committerJohn Darrington <jmd@gnu.org>2016-11-08 21:35:26 +0100
commit859e367d0709aac3c9a63610d7bb1adaba13d27b (patch)
tree225374c7968c78998dc7a2c9b73d45edf8a2f6b9
parent8ae60404510fedb89502e27c0e73f830ab429641 (diff)
downloadgnu-guix-859e367d0709aac3c9a63610d7bb1adaba13d27b.tar
gnu-guix-859e367d0709aac3c9a63610d7bb1adaba13d27b.tar.gz
gnu: Add pam-krb5 service.
* doc/guix.texi (Kerberos Services): New node. * gnu/services/kerberos.scm: New file. * gnu/local.mk: Add it.
-rw-r--r--doc/guix.texi38
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/services/kerberos.scm67
3 files changed, 105 insertions, 1 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index d99f409061..89a7a5867e 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -221,6 +221,7 @@ Services
* Desktop Services:: D-Bus and desktop services.
* Database Services:: SQL databases.
* Mail Services:: IMAP, POP3, SMTP, and all that.
+* Kerberos Services:: Kerberos services.
* Web Services:: Web servers.
* Network File System:: NFS related services.
* Miscellaneous Services:: Other services.
@@ -7701,6 +7702,7 @@ declaration.
* Desktop Services:: D-Bus and desktop services.
* Database Services:: SQL databases.
* Mail Services:: IMAP, POP3, SMTP, and all that.
+* Kerberos Services:: Kerberos services.
* Web Services:: Web servers.
* Network File System:: NFS related services.
* Miscellaneous Services:: Other services.
@@ -10405,6 +10407,40 @@ could instantiate a dovecot service like this:
(string "")))
@end example
+
+@node Kerberos Services
+@subsubsection Kerberos Services
+@cindex Kerberos
+
+The @code{(gnu services Kerberos)} module provides services relating to
+the authentication protocol @dfn{Kerberos}.
+
+@subsubheading PAM krb5 Service
+@cindex pam-krb5
+
+The pam-krb5 service allows for login authentication and password
+management via Kerberos.
+You will need this service if you want PAM enabled applications to authenticate
+users using Kerberos.
+
+@defvr {Scheme Variable} pam-krb5-service-type
+A service type for the Kerberos 5 PAM module.
+@end defvr
+
+@deftp {Data Type} pam-krb5-configuration
+Data type representing the configuration of the Kerberos 5 PAM module
+This type has the following parameters:
+@table @asis
+@item @code{pam-krb5} (default: @code{pam-krb5})
+The pam-krb5 package to use.
+
+@item @code{minimum-uid} (default: @code{1000})
+The smallest user ID for which Kerberos authentications should be attempted.
+Local accounts with lower values will silently fail to authenticate.
+@end table
+@end deftp
+
+
@node Web Services
@subsubsection Web Services
@@ -10538,7 +10574,7 @@ The @dfn{global security system} (GSS) daemon provides strong security for RPC
based protocols.
Before exchanging RPC requests an RPC client must establish a security
context. Typically this is done using the Kerberos command @command{kinit}
-or automatically at login time using PAM services.
+or automatically at login time using PAM services (@pxref{Kerberos Services}).
@defvr {Scheme Variable} gss-service-type
A service type for the Global Security System (GSS) daemon.
diff --git a/gnu/local.mk b/gnu/local.mk
index 73c4dc2cf5..396281357a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -400,6 +400,7 @@ GNU_SYSTEM_MODULES = \
%D%/services/dbus.scm \
%D%/services/desktop.scm \
%D%/services/dict.scm \
+ %D%/services/kerberos.scm \
%D%/services/lirc.scm \
%D%/services/mail.scm \
%D%/services/mcron.scm \
diff --git a/gnu/services/kerberos.scm b/gnu/services/kerberos.scm
new file mode 100644
index 0000000000..144c71bba0
--- /dev/null
+++ b/gnu/services/kerberos.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services kerberos)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu services)
+ #:use-module (gnu system pam)
+ #:use-module (guix gexp)
+ #:use-module (guix records)
+ #:export (pam-krb5-configuration
+ pam-krb5-configuration?
+ pam-krb5-service-type))
+
+(define-record-type* <pam-krb5-configuration>
+ pam-krb5-configuration make-pam-krb5-configuration
+ pam-krb5-configuration?
+ (pam-krb5 pam-krb5-configuration-pam-krb5
+ (default pam-krb5))
+ (minimum-uid pam-krb5-configuration-minimum-uid
+ (default 1000)))
+
+(define (pam-krb5-pam-service config)
+ "Return a PAM service for Kerberos authentication."
+ (lambda (pam)
+ (define pam-krb5-module
+ #~(string-append #$(pam-krb5-configuration-pam-krb5 config) "/lib/security/pam_krb5.so"))
+
+ (let ((pam-krb5-sufficient
+ (pam-entry
+ (control "sufficient")
+ (module pam-krb5-module)
+ (arguments (list
+ (format #f "minimum_uid=~a"
+ (pam-krb5-configuration-minimum-uid config)))))))
+ (pam-service
+ (inherit pam)
+ (auth (cons* pam-krb5-sufficient
+ (pam-service-auth pam)))
+ (session (cons* pam-krb5-sufficient
+ (pam-service-session pam)))
+ (account (cons* pam-krb5-sufficient
+ (pam-service-account pam)))))))
+
+(define (pam-krb5-pam-services config)
+ (list (pam-krb5-pam-service config)))
+
+(define pam-krb5-service-type
+ (service-type (name 'pam-krb5)
+ (extensions
+ (list
+ (service-extension pam-root-service-type
+ pam-krb5-pam-services)))))