summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-11-05 12:27:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-06 19:53:13 +0000
commit4a0933307e21051ad16d869e6ab3833291052b60 (patch)
tree913a96a52ae378598cc6a8b912fbdc813517b7e7
parent290ad2243c0ce2919918f64fec5652b5a60466a8 (diff)
downloadgnu-guix-4a0933307e21051ad16d869e6ab3833291052b60.tar
gnu-guix-4a0933307e21051ad16d869e6ab3833291052b60.tar.gz
gnu: Add python-pycodestyle.
* gnu/packages/python.scm (python-pycodestyle, python2-pycodestyle): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 54360b3c71..20a0a74115 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3854,6 +3854,34 @@ simple and Pythonic domain language.")
(define-public python2-sqlalchemy
(package-with-python2 python-sqlalchemy))
+(define-public python-pycodestyle
+ (package
+ (name "python-pycodestyle")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycodestyle" version))
+ (sha256
+ (base32
+ "1rz2v8506mdjdyxcnv9ygiw6v0d4dqx8z5sjyjm0w2v32h5l5w1p"))))
+ (build-system python-build-system)
+ (home-page "https://pycodestyle.readthedocs.io/")
+ (synopsis "Python style guide checker")
+ (description "@code{pycodestyle} (formerly pep8) is a tool to check
+Python code against some of the style conventions in
+@url{http://www.python.org/dev/peps/pep-0008/,PEP 8}.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pycodestyle))))))
+
+(define-public python2-pycodestyle
+ (let ((base (package-with-python2 (strip-python2-variant
+ python-pycodestyle))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))
+
(define-public python-sqlalchemy-utils
(package
(name "python-sqlalchemy-utils")