summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-11-10 01:09:04 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-12 16:17:40 +0100
commit0a7f17f0e02bb5434fc9b23b6a46897c0ea34782 (patch)
tree04fa8c055fbea65afbba9eff818f57047c058ba2
parent1e6112d89fd9c43dc040993be6fba0d34e4e9e12 (diff)
downloadgnu-guix-0a7f17f0e02bb5434fc9b23b6a46897c0ea34782.tar
gnu-guix-0a7f17f0e02bb5434fc9b23b6a46897c0ea34782.tar.gz
gnu: Add python-flask-restplus.
* gnu/packages/python.scm (python-flask-restplus): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0d3c7aeac9..d79d8488b2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12213,3 +12213,34 @@ asynchronous messaging environments.")
(description "This package provides colored output for the
@command{nosetests} command of the Python Nose unit test framework.")
(license license:bsd-3)))
+
+(define-public python-flask-restplus
+ (package
+ (name "python-flask-restplus")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flask-restplus" version))
+ (sha256
+ (base32
+ "11his6ii5brpkhld0d5bwzjjw4q3vmplpd6fmgzjrvvklsbk0cf4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aniso8601" ,python-aniso8601)
+ ("python-flask" ,python-flask)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-pytz" ,python-pytz)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-tzlocal" ,python-tzlocal)
+ ("python-blinker" ,python-blinker)
+ ("python-nose" ,python-nose)
+ ("python-rednose" ,python-rednose)))
+ (home-page "https://github.com/noirbizarre/flask-restplus")
+ (synopsis "Framework for documented API development with Flask")
+ (description "This package provides a framework for API development with
+the Flask web framework in Python. It is similar to package
+@code{python-flask-restful} but supports the @code{python-swagger}
+documentation builder.")
+ (license license:expat)))