summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:46 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:24:00 +0200
commitff932b7e635d5484cdd2d41a09b5792a25bbe200 (patch)
treed4be91f2d8d5edbc67504b55aa8d23e90f05fd6b
parent3abe72bdb4b5228efdc661ab4fb545376f1abb6e (diff)
downloadgnu-guix-ff932b7e635d5484cdd2d41a09b5792a25bbe200.tar
gnu-guix-ff932b7e635d5484cdd2d41a09b5792a25bbe200.tar.gz
gnu: Add ghc-wai-conduit.
* gnu/packages/haskell.scm (ghc-wai-conduit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0bafdf6f61..108fbfc1f6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8295,4 +8295,29 @@ advanced user's otherwise working script to fail under future circumstances.
@end enumerate")
(license license:gpl3+)))
+(define-public ghc-wai-conduit
+ (package
+ (name "ghc-wai-conduit")
+ (version "3.0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "wai-conduit-" version "/"
+ "wai-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zvsiwjq2mvkb9sjgp3ly9m968m7a2jjzr4id6jpi3mmqykj15z4"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)))
+ (home-page "https://github.com/yesodweb/wai")
+ (synopsis "Conduit wrappers for Haskell's WAI")
+ (description "This package provides data streaming abstraction for
+Haskell's Web Application Interface (WAI).")
+ (license license:expat)))
+
;;; haskell.scm ends here