summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:47 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:26:15 +0200
commitd14e3435caa6e23ea1d03393dae1fc9f2cb5275d (patch)
tree7d737f857462c3a0cefe418d37f550d305329f6e
parentff932b7e635d5484cdd2d41a09b5792a25bbe200 (diff)
downloadgnu-guix-d14e3435caa6e23ea1d03393dae1fc9f2cb5275d.tar
gnu-guix-d14e3435caa6e23ea1d03393dae1fc9f2cb5275d.tar.gz
gnu: Add ghc-http-date.
* gnu/packages/haskell.scm (ghc-http-date): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 108fbfc1f6..b52aa9f0f5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8320,4 +8320,31 @@ advanced user's otherwise working script to fail under future circumstances.
Haskell's Web Application Interface (WAI).")
(license license:expat)))
+(define-public ghc-http-date
+ (package
+ (name "ghc-http-date")
+ (version "0.0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "http-date-" version "/"
+ "http-date-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dknh28kyarnzqrsc80ssalxjrq0qbv7ir49247p2grb7rh0dqgj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)))
+ (native-inputs
+ `(("ghc-doctest" ,ghc-doctest)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)
+ ("ghc-old-locale" ,ghc-old-locale)))
+ (home-page "https://github.com/kazu-yamamoto/http-date")
+ (synopsis "HTTP Date parser/formatter")
+ (description "Library for Parsing and formatting HTTP
+Date in Haskell.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here