summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-15 02:49:22 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-15 11:17:28 -0400
commit240cee8ab42efd77b1a7962173209e9678f2f019 (patch)
tree4bf14f433b3514e56106130082599dfd39531866
parent0c5a8007fe3cfc792bf5f692342a84165f706441 (diff)
downloadgnu-guix-240cee8ab42efd77b1a7962173209e9678f2f019.tar
gnu-guix-240cee8ab42efd77b1a7962173209e9678f2f019.tar.gz
gnu: network-manager-applet: Update to 1.8.2.
* gnu/packages/gnome.scm (network-manager-applet): Update to 1.8.2. [arguments]: Remove "--without-wwan" configure flag. [inputs]: Add libselinux and modem-manager.
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 20222ed9be..e14abcfa37 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -104,6 +104,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages rdesktop)
#:use-module (gnu packages scanner)
+ #:use-module (gnu packages selinux)
#:use-module (gnu packages ssh)
#:use-module (gnu packages xml)
#:use-module (gnu packages gl)
@@ -4806,7 +4807,7 @@ services.")
(define-public network-manager-applet
(package
(name "network-manager-applet")
- (version "1.4.2")
+ (version "1.8.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4814,12 +4815,9 @@ services.")
name "-" version ".tar.xz"))
(sha256
(base32
- "16a43sl9aijmvxbb08hbjqyjnlshj8dckycbgi9nm333fr47n6s3"))))
+ "09f9hjpn9nkhw57mk6pi7q1bq3lhf5hvmwas0fknscssak7yjmry"))))
(build-system glib-or-gtk-build-system)
- ;; TODO: WWAN support supposedly requires an update of glibmm which in turn
- ;; requires an update of the its dependencies (glib and others).
- (arguments '(#:configure-flags '("--disable-migration"
- "--without-wwan")))
+ (arguments '(#:configure-flags '("--disable-migration")))
(native-inputs
`(("intltool" ,intltool)
("gobject-introspection" ,gobject-introspection)
@@ -4834,7 +4832,9 @@ services.")
("libgudev" ,libgudev)
("libnotify" ,libnotify)
("libsecret" ,libsecret)
- ("jansson" ,jansson))) ;for team support
+ ("libselinux" ,libselinux)
+ ("jansson" ,jansson) ; for team support
+ ("modem-manager" ,modem-manager)))
(synopsis "Applet for managing network connections")
(home-page "http://www.gnome.org/projects/NetworkManager/")
(description