summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-21 16:35:58 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-25 14:47:58 +0200
commitf27522d6db86bac64eea7717fb73d6e071f405e1 (patch)
tree8b8225a1de522fdd07b1d665c974469d975a40eb
parent38cb1ec64b9ef9f3f23d4ad6348b2a1301a9f58c (diff)
downloadgnu-guix-f27522d6db86bac64eea7717fb73d6e071f405e1.tar
gnu-guix-f27522d6db86bac64eea7717fb73d6e071f405e1.tar.gz
gnu: Add ocaml-re.
* gnu/packages/ocaml.scm (ocaml-re): New variable.
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 88d335f36e..51383f77ff 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2810,3 +2810,29 @@ first class values representing record fields, and additional routines, to get
and set record fields, iterate and fold over all fields of a record and create
new record values.")
(license license:asl2.0)))
+
+(define-public ocaml-re
+ (package
+ (name "ocaml-re")
+ (version "1.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ocaml/ocaml-re//archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s3rcr76cgm4p1xmaazc58arkg2lz3zfcp1icm00m6s5ccnkh67b"))))
+ (build-system ocaml-build-system)
+ (native-inputs `(("ounit" ,ocaml-ounit)))
+ (home-page "https://github.com/ocaml/ocaml-re/")
+ (synopsis "Regular expression library for OCaml")
+ (description "Pure OCaml regular expressions with:
+@enumerate
+@item Perl-style regular expressions (module Re_perl)
+@item Posix extended regular expressions (module Re_posix)
+@item Emacs-style regular expressions (module Re_emacs)
+@item Shell-style file globbing (module Re_glob)
+@item Compatibility layer for OCaml's built-in Str module (module Re_str)
+@end enumerate")
+ (license license:expat)))