summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-21 16:29:45 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-25 14:47:45 +0200
commit3674d7df2f9fc7300038058fed758fc40d092f99 (patch)
tree49207e169f8d097692731213e8b4d89fbc8b285f
parent25941ca13b483758802d9b68abd40b6cb73df8cf (diff)
downloadgnu-guix-3674d7df2f9fc7300038058fed758fc40d092f99.tar
gnu-guix-3674d7df2f9fc7300038058fed758fc40d092f99.tar.gz
gnu: Add ocaml-ppx-pipebang.
* gnu/packages/ocaml.scm (ocaml-ppx-pipebang): New variable.
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0a1174402d..a39c5399c9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2673,3 +2673,24 @@ match expressions, and if expressions.")
(description "A ppx rewriter that simplifies building s-expressions from
ocaml values.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-pipebang
+ (package
+ (name "ocaml-ppx-pipebang")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_pipebang" version
+ "1965c7hymp26ncmjs0pfxi2s5jlj60z2c9b194lgcwxqiav56pcw"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-core" ,ocaml-ppx-core)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_pipebang/")
+ (synopsis "Inline reverse application operators `|>` and `|!`")
+ (description "A ppx rewriter that inlines reverse application operators
+@code{|>} and @code{|!}.")
+ (license license:asl2.0)))