summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-25 08:46:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-25 08:48:44 +0200
commit2eb676819f712d894dff47aa44196d1abcce883f (patch)
tree7124aa3e9459029c6536a59fa8e01031e1a57d2d
parent9619a95ed8bbc400af6536e9619cf9c65a5833eb (diff)
downloadgnu-guix-2eb676819f712d894dff47aa44196d1abcce883f.tar
gnu-guix-2eb676819f712d894dff47aa44196d1abcce883f.tar.gz
gnu: qtox: Update to 1.10.1.
* gnu/packages/messaging.scm (qtox): Update to 1.10.1. [inputs]: Remove libtoxcore and qt; add c-toxcore, qtbase, and qtsvg. [native-inputs]: Remove qt; add qttools. [build-system]: Change to cmake-build-system. [arguments]: Remove configure phase replacement.
-rw-r--r--gnu/packages/messaging.scm53
1 files changed, 24 insertions, 29 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 89df0970d6..c22d3d4dc8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -756,48 +756,43 @@ instant messenger with audio and video chat capabilities.")
(define-public qtox
(package
(name "qtox")
- (version "1.5.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/qTox/qTox/archive/v"
- version ".tar.gz"))
- (sha256
- (base32 "0y15mc39x54k1kz36cw9412kl1p1p6nzlx97gagv4gg3vybfhbjv"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (version "1.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/qTox/qTox/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0b37an611i2jdri59vsspyl3yf6cn4h0bn9d2jdrkw8d2rfqc8qy"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-reproducibility-issues
+ (lambda _
+ (substitute* "src/main.cpp"
+ (("__DATE__") "\"\"")
+ (("__TIME__") "\"\"")
+ (("TIMESTAMP") "\"\""))
+ #t)))))
(inputs
`(("ffmpeg" ,ffmpeg)
("glib" ,glib)
("gtk+" ,gtk+-2)
("libsodium" ,libsodium)
- ("libtoxcore" ,libtoxcore)
+ ("c-toxcore" ,c-toxcore)
("libvpx" ,libvpx)
("libxscrnsaver" ,libxscrnsaver)
("libx11" ,libx11)
("openal" ,openal)
("qrencode" ,qrencode)
- ("qt" ,qt)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
("sqlcipher" ,sqlcipher)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("qmake" ,qt)))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-reproducibility-issues
- (lambda _
- (substitute* "src/main.cpp"
- (("__DATE__") "\"\"")
- (("__TIME__") "\"\"")
- (("TIMESTAMP") "\"\""))
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (zero?
- (system* "qmake"
- (string-append "PREFIX="
- (assoc-ref outputs "out")))))))))
+ ("qmake" ,qttools)))
(home-page "https://qtox.github.io/")
(synopsis "Tox chat client using Qt")
(description "qTox is a Tox client that follows the Tox design