summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-05-27 17:05:16 +0200
committerLeo Famulari <leo@famulari.name>2019-05-27 14:32:13 -0400
commited72a133dbba02cd1d49a19e0a6391ce9384840e (patch)
tree587d66cb0ffcf5e09e0b2c2c6fa74c0723d1d552
parent521d736ae97ef34f4e6136c7175a99c680c5ac95 (diff)
downloadgnu-guix-ed72a133dbba02cd1d49a19e0a6391ce9384840e.tar
gnu-guix-ed72a133dbba02cd1d49a19e0a6391ce9384840e.tar.gz
gnu: Add osmctools
* gnu/packages/geo.scm (osmctools): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/geo.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 94f2cf0cfb..ec5ace3519 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -840,3 +842,30 @@ map, geocoding with Nominatim, or general analysis.")
the texture and density of features is visible at every zoom level, instead of
dropping features at lower levels.")
(license license:bsd-2)))
+
+(define-public osmctools
+ (package
+ (name "osmctools")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/osm-c-tools/osmctools")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m8d3r1q1v05pkr8k9czrmb4xjszw6hvgsf3kn9pf0v14gpn4r8f"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://gitlab.com/osm-c-tools/osmctools")
+ (synopsis "Tools to convert, filter and update OpenStreetMap data files")
+ (description "This project contains a few tools which are used in the
+OpenStreetMap project. They can be used to convert, filter and update
+OpenStreetMap data files.")
+ (license license:agpl3)))