summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-19 20:58:21 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-06 11:08:34 +0200
commita08530df08b943f2131873e9f86e326477dfa1c7 (patch)
tree327f4c9b991667e823c88937ea7667360b2e11b3
parent5e319c15c18e3243b2800520c176ccde848b4c97 (diff)
downloadgnu-guix-a08530df08b943f2131873e9f86e326477dfa1c7.tar
gnu-guix-a08530df08b943f2131873e9f86e326477dfa1c7.tar.gz
gnu: Add emacs-names.
* gnu/packages/emacs-xyz.scm (emacs-names): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 367f46f264..b33502fc2a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2719,6 +2719,30 @@ the speedbar window.")
"This package provides commands to quickly switch between shell buffers.")
(license license:gpl3+)))
+(define-public emacs-names
+ (let ((commit "d8baba5360e5253938a25d3e005455b6d2d86971")
+ (version "20151201.0")
+ (revision "8"))
+ (package
+ (name "emacs-names")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Malabarba/names")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11wyha2q8y7bzqq3jrzix8n97ywvsibvddrahqcps1a1yqk4hzfz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Malabarba/names/")
+ (synopsis "Namespace implementation for Emacs Lisp")
+ (description
+ "This package provides a macro that writes your namespaces for you.")
+ (license license:gpl3+))))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")