summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-12 22:05:50 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-12 22:18:44 +0200
commit9d77da2a47ddb707edcbd1ca17f5c0ac3c068b04 (patch)
tree0288082be597f1fe550cd4ec816e420aec6e0698
parent66ea98e321e93b0806f6870d77dd4c00e7e720c0 (diff)
downloadgnu-guix-9d77da2a47ddb707edcbd1ca17f5c0ac3c068b04.tar
gnu-guix-9d77da2a47ddb707edcbd1ca17f5c0ac3c068b04.tar.gz
gnu: util-linux: Don't install 'logger'.
* gnu/packages/linux.scm (util-linux)[source]: Add 'snippet'.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7be0d076ec..04d0458dc9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -378,7 +378,16 @@ providing the system administrator with some help in common tasks.")
(sha256
(base32
"1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))
- (patches (list (search-patch "util-linux-perl.patch")))))
+ (patches (list (search-patch "util-linux-perl.patch")))
+ (modules '((guix build utils)))
+ (snippet
+ ;; We take the 'logger' program from GNU Inetutils, so remove
+ ;; it from here.
+ '(substitute* "misc-utils/Makefile.in"
+ (("PROGRAMS =(.*) logger(.*)" _ before after)
+ (string-append "PROGRAMS =" before " " after))
+ (("MANS =(.*) logger\\.1(.*)" _ before after)
+ (string-append "MANS =" before " " after))))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-use-tty-group"