summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 17:51:09 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 18:28:49 +0200
commitb858c5ac3911eacf5961809216737ac557e4aa63 (patch)
tree1008c1863cdaa27e65ef524daa925ec82d631d8b
parent44b8507d5eb227ac26fcad7121b12e1d1058a314 (diff)
downloadgnu-guix-b858c5ac3911eacf5961809216737ac557e4aa63.tar
gnu-guix-b858c5ac3911eacf5961809216737ac557e4aa63.tar.gz
gnu: ocaml-ssl: Update to 0.5.7.
* gnu/packages/ocaml.scm (ocaml-ssl): Update to 0.5.7.
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6bc042dbdc..512c9141e1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1781,7 +1781,7 @@ lets the client choose the concrete timeline.")
(define-public ocaml-ssl
(package
(name "ocaml-ssl")
- (version "0.5.5")
+ (version "0.5.7")
(source
(origin
(method git-fetch)
@@ -1790,21 +1790,10 @@ lets the client choose the concrete timeline.")
(commit version)))
(file-name (git-file-name name version))
(sha256 (base32
- "0fviq8xhp3qk7pmkl7knchywsipxgb7p0z489hj8qnf2sx8xzdmy"))))
- (build-system ocaml-build-system)
+ "06zxqnwqkvf7pmj5s44jflkknv01czgbi4nbaac0ys1p7rv99y3x"))))
+ (build-system dune-build-system)
(arguments
- `(#:tests? #f
- #:make-flags (list "OCAMLFIND_LDCONF=ignore")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda* (#:key #:allow-other-keys)
- (system* "sh" "bootstrap")
- (substitute* "src/OCamlMakefile"
- (("/bin/sh") (which "bash")))
- (substitute* "configure"
- (("/bin/sh") (which "bash")))
- #t)))))
+ `(#:test-target "."))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)