summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 21:50:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:51 +0200
commit63b9f87ae452f1882d90ca3d6c17ced377bd68a1 (patch)
tree5f5e82476ac5dc68d797f3ee122b30c8679fb667
parent979df8c45256f88f8d1e7cf3c42ef407bf8ea2c3 (diff)
downloadgnu-guix-63b9f87ae452f1882d90ca3d6c17ced377bd68a1.tar
gnu-guix-63b9f87ae452f1882d90ca3d6c17ced377bd68a1.tar.gz
gnu: Add perl6-grammar-profiler-simple.
* gnu/packages/perl6.scm (perl6-grammar-profiler-simple): New variable.
-rw-r--r--gnu/packages/perl6.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index cf8a400e8e..a0d9343ec6 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -228,6 +228,33 @@ regular expression engine for the virtual machine.")
specification and runs on top of several virtual machines.")
(license license:artistic2.0)))
+(define-public perl6-grammar-profiler-simple
+ ;; Last commit was June 2017
+ (let ((commit "c0aca5fab323b2974821dabd6b89330c609e0b7d")
+ (revision "1"))
+ (package
+ (name "perl6-grammar-profiler-simple")
+ (version (git-version "0.02" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/perlpilot/Grammar-Profiler-Simple.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/perlpilot/Grammar-Profiler-Simple")
+ (synopsis "Simple rule profiling for Perl 6 grammars")
+ (description "This module provides a simple profiler for Perl 6 grammars.
+To enable profiling simply add use @code{Grammar::Profiler::Simple;} to your
+code. Any grammar in the lexical scope of the use statement will automatically
+have profiling information collected when the grammar is used.")
+ (license license:artistic2.0))))
+
(define-public perl6-json-class
(package
(name "perl6-json-class")