summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-28 09:11:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:49 +0200
commit60945c67bb04b910c25452a548952f07da27383b (patch)
treeea7e17df97ed0fa4c7476f59cbaddf74da8304f6
parent74809e9e6fc0cb3c9df30556f4f68209f8598045 (diff)
downloadgnu-guix-60945c67bb04b910c25452a548952f07da27383b.tar
gnu-guix-60945c67bb04b910c25452a548952f07da27383b.tar.gz
gnu: Add perl6-uri.
* gnu/packages/perl6.scm (perl6-uri): New variable.
-rw-r--r--gnu/packages/perl6.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index aea2809066..c65ba8361b 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -258,6 +258,30 @@ TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
+(define-public perl6-uri
+ (package
+ (name "perl6-uri")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/perl6-community-modules/uri.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h318g75jqn2ckw051g35iqyfxz1mps0jyg5z6pd857y3kacbkpl"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/perl6-community-modules/uri")
+ (synopsis "URI implementation using Perl 6")
+ (description "A URI implementation using Perl 6 grammars to implement RFC
+3986 BNF. Currently only implements parsing. Includes @code{URI::Escape} to
+(un?)escape characters that aren't otherwise allowed in a URI with % and a hex
+character numbering.")
+ (license license:artistic2.0)))
+
(define-public perl6-zef
(package
(name "perl6-zef")