summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-28 11:48:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:49 +0200
commit56eea221374be83a0718d1c66873f85b2b30c448 (patch)
treedd38f7240e07fe816aa6a9096f02d55a66002991
parentbc7c6efeaa8f4146d28bc8061665ebe68f75aa9f (diff)
downloadgnu-guix-56eea221374be83a0718d1c66873f85b2b30c448.tar
gnu-guix-56eea221374be83a0718d1c66873f85b2b30c448.tar.gz
gnu: Add perl6-json-unmarshal.
* gnu/packages/perl6.scm (perl6-json-unmarshal): New variable.
-rw-r--r--gnu/packages/perl6.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index c2c1c50f70..d2f682096c 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -278,6 +278,33 @@ It will of course also be needed in classes thar are going to use
@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
(license license:artistic2.0)))
+(define-public perl6-json-unmarshal
+ ;; Last commit was May 2017
+ (let ((commit "e1b6288c5f3165058f36c0f4e171cdf2dfd640da")
+ (revision "1"))
+ (package
+ (name "perl6-json-unmarshal")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tadzik/JSON-Unmarshal.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14azsmzmwdn8k0gqcpvballharcvzylmlyrx2wmv4kpqfnz29fjc"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-json-fast" ,perl6-json-fast)
+ ("perl6-json-name" ,perl6-json-name)))
+ (home-page "https://github.com/tadzik/JSON-Unmarshal")
+ (synopsis "Make JSON from an Object")
+ (description "This library provides a single exported subroutine to
+create an object from a JSON representation of an object.")
+ (license license:expat))))
+
(define-public perl6-tap-harness
(package
(name "perl6-tap-harness")