summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 21:32:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:51 +0200
commit56930271b9935da40e84b928fa7db9d590c90f6e (patch)
treeb70b362f6ab059b6b1c7952dea5640d910c5a900
parent4af100644097a4b0f9313247cd3b95429dcf5178 (diff)
downloadgnu-guix-56930271b9935da40e84b928fa7db9d590c90f6e.tar
gnu-guix-56930271b9935da40e84b928fa7db9d590c90f6e.tar.gz
gnu: Add perl6-oo-monitors.
* gnu/packages/perl6.scm (perl6-oo-monitors): New variable.
-rw-r--r--gnu/packages/perl6.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index fb594c790f..8c6c27a42d 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -422,6 +422,32 @@ as per the spec and where known the places that @quot{customary} attributes are
used.")
(license license:artistic2.0)))
+(define-public perl6-oo-monitors
+ (package
+ (name "perl6-oo-monitors")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jnthn/oo-monitors")
+ ;; The commit where 1.1 was "tagged"
+ (commit "494db3a3852854f30a80c9bd1489a7d5e429e7c5")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sbw2x54wwjjanghjnc7ipmplaw1srvbrphsdv4ym6cipnbmbj9x"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/jnthn/oo-monitors")
+ (synopsis "Monitors with condition variables for Perl 6")
+ (description "A monitor provides per-instance mutual exclusion for objects.
+This means that for a given object instance, only one thread can ever be inside
+its methods at a time. This is achieved by a lock being associated with each
+object. The lock is acquired automatically at the entry to each method in the
+monitor. Condition variables are also supported.")
+ (license license:artistic2.0)))
+
(define-public perl6-svg
;; Latest commit, basically unchanged since August 2015
(let ((commit "07190c0602aa276e5319f06aa0012452dbff3582")