summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-09 22:14:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-23 22:26:50 +0200
commit505b979272e9a23f94a78b9bc9a7934eab941483 (patch)
tree0056fdde53a9960293de47fd00ad22a8803f46cf
parentea856c08cdede46127003170052d833bc0f2f9b4 (diff)
downloadgnu-guix-505b979272e9a23f94a78b9bc9a7934eab941483.tar
gnu-guix-505b979272e9a23f94a78b9bc9a7934eab941483.tar.gz
gnu: Add perl6-meta6.
* gnu/packages/perl6.scm (perl6-meta6): New variable.
-rw-r--r--gnu/packages/perl6.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 6ab6d71545..d41167d2bb 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -363,6 +363,40 @@ It will of course also be needed in classes thar are going to use
create an object from a JSON representation of an object.")
(license license:expat))))
+(define-public perl6-meta6
+ (package
+ (name "perl6-meta6")
+ (version "0.0.23")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/META6.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xnlaamfbdlfb2zidim3bbc4mawsrg6qxhxi6gbld46z1cyry1cw"))))
+ (build-system rakudo-build-system)
+ (propagated-inputs
+ `(("perl6-json-class" ,perl6-json-class)))
+ (native-inputs
+ `(("perl6-json-fast" ,perl6-json-fast)))
+ (home-page "https://github.com/jonathanstowe/META6")
+ (synopsis "Do things with Perl 6 [META files]")
+ (description "This provides a representation of the Perl 6 META files
+specification - the META file data can be read, created, parsed and written in a
+manner that is conformant with the specification.
+
+Where they are known about it also makes allowance for @quot{customary} usage in
+existing software (such as installers and so forth.)
+
+The intent of this is allow the generation and testing of META files for module
+authors, so it can provide meta-information whether the attributes are mandatory
+as per the spec and where known the places that @quot{customary} attributes are
+used.")
+ (license license:artistic2.0)))
+
(define-public perl6-tap-harness
(package
(name "perl6-tap-harness")