summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:23:20 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-02-24 20:34:02 +0000
commit86679dac1c25972a0269714eaabf7f96ef2c36d9 (patch)
treea5b92f5e74fa8f1f60ec8efe528e422b76b02595
parent121f95ff633d8f45292c9f3021f5c0184e9a7d25 (diff)
downloadgnu-guix-86679dac1c25972a0269714eaabf7f96ef2c36d9.tar
gnu-guix-86679dac1c25972a0269714eaabf7f96ef2c36d9.tar.gz
gnu: Add ruby-rspec-rails.
* gnu/packages/ruby.scm (ruby-rspec-support): Export this variable, so that it's accessible from the (gnu packages rails) module. * gnu/packages/rails.scm (ruby-rspec-rails): New variable.
-rw-r--r--gnu/packages/rails.scm30
-rw-r--r--gnu/packages/ruby.scm2
2 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index 8823791405..339b68d580 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -174,6 +174,36 @@ an almost zero-configuration persistence layer for applications.")
(home-page "https://rubyonrails.org")
(license license:expat)))
+(define-public ruby-rspec-rails
+ (package
+ (name "ruby-rspec-rails")
+ (version "3.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rspec-rails" version))
+ (sha256
+ (base32
+ "1pf6n9l4sw1arlax1bdbm1znsvl8cgna2n6k6yk1bi8vz2n73ls1"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("ruby-actionpack" ,ruby-actionpack)
+ ("ruby-activesupport" ,ruby-activesupport)
+ ("ruby-railties" ,ruby-railties)
+ ("ruby-rspec-core" ,ruby-rspec-core)
+ ("ruby-rspec-expectations" ,ruby-rspec-expectations)
+ ("ruby-rspec-mocks" ,ruby-rspec-mocks)
+ ("ruby-rspec-support" ,ruby-rspec-support)))
+ (synopsis "Use RSpec to test Ruby on Rails applications")
+ (description
+ "This package provides support for using RSpec to test Ruby on Rails
+applications, in pace of the default Minitest testing library.")
+ (home-page "https://github.com/rspec/rspec-rails")
+ (license license:expat)))
+
(define-public ruby-rails-html-sanitizer
(package
(name "ruby-rails-html-sanitizer")
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 17c1d72776..cb5be482f5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -385,7 +385,7 @@ notebook).")
;; RSpec is the dominant testing library for Ruby projects. Even RSpec's
;; dependencies use RSpec for their test suites! To avoid these circular
;; dependencies, we disable tests for all of the RSpec-related packages.
-(define ruby-rspec-support
+(define-public ruby-rspec-support
(package
(name "ruby-rspec-support")
(version "3.8.0")