summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-03 22:03:34 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-02-24 20:34:02 +0000
commit4dce6cc0ae88f6c19679b8a0fec7414e7e1ecf62 (patch)
tree40ccdb913739fa1d07d76e063c82497ba9344fea
parent67b90bd3e2839f49f7f751c9a150bf69d5300e71 (diff)
downloadgnu-guix-4dce6cc0ae88f6c19679b8a0fec7414e7e1ecf62.tar
gnu-guix-4dce6cc0ae88f6c19679b8a0fec7414e7e1ecf62.tar.gz
gnu: postgresql: Build with openssl support.release_30
* gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to [inputs]: Add openssl.
-rw-r--r--gnu/packages/databases.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 306a2b7645..8fa04bff1a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -761,7 +761,7 @@ as a drop-in replacement of MySQL.")
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-uuid=e2fs")
+ `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
@@ -780,6 +780,7 @@ as a drop-in replacement of MySQL.")
(inputs
`(("readline" ,readline)
("libuuid" ,util-linux)
+ ("openssl" ,openssl)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")