summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-23 17:33:36 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:17 +0100
commitfbf6045e33abe06c8190078d6691c3b97758fd6a (patch)
tree7a47b1a9e7768ce8fcd9c62c9f65ed4cd4b12a58
parenta28d646b635a3515135265aef0a4979abe24fe34 (diff)
downloadgnu-guix-fbf6045e33abe06c8190078d6691c3b97758fd6a.tar
gnu-guix-fbf6045e33abe06c8190078d6691c3b97758fd6a.tar.gz
gnu: Add plotly.
* gnu/packages/statistics.scm (r-plotly): New variable.
-rw-r--r--gnu/packages/statistics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index fefb71751c..5b98c912e4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1913,3 +1913,33 @@ black-and-white. They are also designed to be perceived by readers with the
most common form of color blindness.")
(license license:x11)))
+(define-public r-plotly
+ (package
+ (name "r-plotly")
+ (version "2.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "plotly" version))
+ (sha256
+ (base32
+ "16pqycns8qf0y1j21n009qf242lv0izwyidlx40zv88izxhg1vs0"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-digest" ,r-digest)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-magrittr" ,r-magrittr)
+ ("r-plyr" ,r-plyr)
+ ("r-viridis" ,r-viridis)))
+ (home-page "https://plot.ly/r")
+ (synopsis "Create interactive web graphics")
+ (description
+ "This package enables the translation of ggplot2 graphs to an interactive
+web-based version and/or the creation of custom web-based visualizations
+directly from R. Once uploaded to a plotly account, plotly graphs (and the
+data behind them) can be viewed and modified in a web browser.")
+ (license license:x11)))
+