summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:47:42 +0100
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-01-30 01:30:57 +0000
commit28a1381ec27a589d297f9cb088ba981d29132747 (patch)
treea5fa721e162cb2241a4cff615bc39fb9b8e6e9ef
parentbce5bca7588074c1d7f85c13362aa57749daf7ea (diff)
downloadgnu-guix-28a1381ec27a589d297f9cb088ba981d29132747.tar
gnu-guix-28a1381ec27a589d297f9cb088ba981d29132747.tar.gz
gnu: Add ruby-execjs.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 92918c0651..7e3ddded5c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1218,6 +1218,31 @@ support.")
(home-page "http://www.kuwata-lab.com/erubis/")
(license license:expat)))
+(define-public ruby-execjs
+ (package
+ (name "ruby-execjs")
+ (version "2.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; fetch from github as the gem does not contain testing code
+ (uri (string-append "https://github.com/rails/execjs/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0h1bi96gks205pz2mn2zwldz8h0ajwggyi85bwfbksmrsn2lwick"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests require ruby-therubyracer and thus v8.
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis
+ "ExecJS lets you run JavaScript code from Ruby.")
+ (description
+ "ExecJS lets you run JavaScript code from Ruby.")
+ (home-page "https://github.com/rails/execjs")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")