summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-09-23 22:36:15 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-29 12:39:16 +0200
commitbe7c64ba2d82f6d800ad6577ff8e9e6306071977 (patch)
treef118ba04592221eefdb649116f94e323020abb6a
parent1dc876a39f39b963fbad7af9e38f62d45256432a (diff)
downloadgnu-guix-be7c64ba2d82f6d800ad6577ff8e9e6306071977.tar
gnu-guix-be7c64ba2d82f6d800ad6577ff8e9e6306071977.tar.gz
gnu: Add tegola.
* gnu/packages/geo.scm (tegola): New variable.
-rw-r--r--gnu/packages/geo.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ae6ba024e0..5641c742b4 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -26,6 +26,7 @@
(define-module (gnu packages geo)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system scons)
#:use-module (guix build-system r)
@@ -760,3 +761,48 @@ location queries to be run in SQL.")
license:bsd-3 ; files only say "BSD"
;; doc
license:cc-by-sa3.0))))
+
+(define-public tegola
+ (package
+ (name "tegola")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/go-spatial/tegola/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09vnzxfn0r70kmd776kcdfqxhzdj11syxa0b27z4ci1k367v7viw"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/go-spatial/tegola/cmd/tegola"
+ #:unpack-path "github.com/go-spatial"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-version
+ (lambda _
+ (with-directory-excursion
+ (string-append "src/github.com/go-spatial/tegola-" ,version)
+ (substitute* '("cmd/tegola/cmd/root.go"
+ "cmd/tegola_lambda/main.go")
+ (("version not set") ,version)))
+ #t))
+ (add-before 'build 'rename-import
+ (lambda _
+ (rename-file (string-append "src/github.com/go-spatial/tegola-" ,version)
+ "src/github.com/go-spatial/tegola")
+ #t)))))
+ (home-page "http://tegola.io")
+ (synopsis "Vector tile server for maps")
+ (description "Tegola is a free vector tile server written in Go. Tegola
+takes geospatial data and slices it into vector tiles that can be efficiently
+delivered to any client.")
+ (license (list
+ license:expat
+ ;; Some packages in vendor have other licenses
+ license:asl2.0
+ license:bsd-2
+ license:bsd-3
+ license:wtfpl2))))