summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-05-25 23:25:07 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-05-27 18:47:03 +0200
commit66006fe5264769ee6705271b41ae29cfd534c9a7 (patch)
treea70fdb0fb07d154fa06faafada186535d7282010
parent7049dea1854f5f09ae744578e5666af80246804e (diff)
downloadgnu-guix-66006fe5264769ee6705271b41ae29cfd534c9a7.tar
gnu-guix-66006fe5264769ee6705271b41ae29cfd534c9a7.tar.gz
gnu: Add java-commons-jxpath.
* gnu/packages/java.scm (java-commons-jxpath): New variable.
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 4aef4befa5..e205cccd69 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4263,6 +4263,37 @@ from within Java, as well as an object registry that exposes Java objects to
these scripting language engines.")
(license license:asl2.0)))
+(define-public java-commons-jxpath
+ (package
+ (name "java-commons-jxpath")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/commons/jxpath/source/"
+ "commons-jxpath-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "1rpgg31ayn9fwr4bfi2i1ij0npcg79ad2fv0w9hacvawsyc42cfs"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "commons-jxpath.jar"
+ ;; tests require more dependencies, including mockrunner which depends on old software
+ #:tests? #f
+ #:source-dir "src/java"))
+ (inputs
+ `(("java-tomcat" ,java-tomcat)
+ ("java-jdom" ,java-jdom)
+ ("java-commons-beanutils" ,java-commons-beanutils)))
+ (native-inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "http://commons.apache.org/jxpath/")
+ (synopsis "Simple interpreter of an expression language called XPath.")
+ (description "The org.apache.commons.jxpath package defines a simple
+interpreter of an expression language called XPath. JXPath applies XPath
+expressions to graphs of objects of all kinds: JavaBeans, Maps, Servlet
+contexts, DOM etc, including mixtures thereof.")
+ (license license:asl2.0)))
+
(define-public java-jsr250
(package
(name "java-jsr250")