summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-04-21 09:23:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-04-21 23:07:52 +0200
commit4b1f7a3e905026a55492d4db177a988dd1f2ca21 (patch)
treeb093f2332ce3173181cc7042874b8a228af55bc6
parent0edd2fd18622e4263f36164eac082be31581105c (diff)
downloadgnu-guix-4b1f7a3e905026a55492d4db177a988dd1f2ca21.tar
gnu-guix-4b1f7a3e905026a55492d4db177a988dd1f2ca21.tar.gz
gnu: Add r-openxlsx.
* gnu/packages/cran.scm (r-openxlsx): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8d15415b1a..94f7489efc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3763,3 +3763,26 @@ selection, and goodness-of-fit. Cross-validation tools are also available for
measuring the accuracy of ABC estimates, and to calculate the
misclassification probabilities of different models.")
(license license:gpl3+)))
+
+(define-public r-openxlsx
+ (package
+ (name "r-openxlsx")
+ (version "4.0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "openxlsx" version))
+ (sha256
+ (base32
+ "1mq4lasp12kc30sxcsmz9gskd114l8s7z7wd6svv2nm8qllrhsqi"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/awalker89/openxlsx")
+ (synopsis "Read, write and edit XLSX files")
+ (description
+ "This package simplifies the creation of Excel @code{.xlsx} files by
+providing a high level interface to writing, styling and editing worksheets.
+Through the use of Rcpp, read/write times are comparable to the @code{xlsx}
+and @code{XLConnect} packages with the added benefit of removing the
+dependency on Java.")
+ (license license:gpl3)))