summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-04-21 09:27:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-04-21 23:07:52 +0200
commit284179bbb395000957be4b891be5cf1f76d88c39 (patch)
tree0fdecb8d6bddfe2c3ae2ed81c5cf4d5fff02cee5
parent500224cb4cce6872f595ef0652991bfb606f12c3 (diff)
downloadgnu-guix-284179bbb395000957be4b891be5cf1f76d88c39.tar
gnu-guix-284179bbb395000957be4b891be5cf1f76d88c39.tar.gz
gnu: Add r-later.
* gnu/packages/cran.scm (r-later): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 12f848974c..cc81815bdb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3848,3 +3848,26 @@ exchanging spatial objects with other R packages.")
;; The R code is released under GPL version 2 or later.
(license (list license:gpl2+
license:expat))))
+
+(define-public r-later
+ (package
+ (name "r-later")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "later" version))
+ (sha256
+ (base32
+ "0z9jymmclkq9zcg1fd8p6gsnm5z1sn3n9pfz3bs03qjrkbizgrvz"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bh" ,r-bh)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://github.com/r-lib/later")
+ (synopsis "Utilities for delaying function execution")
+ (description
+ "This package provides tools to execute arbitrary R or C functions some
+time after the current time, after the R execution stack has emptied.")
+ (license license:gpl2+)))