summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-04 13:23:38 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-09 18:18:48 +0000
commitda90f337b31d53d3dc293a83e069984c70cde2ad (patch)
tree1489383b8afccf8febdb786ccef3cea5a512f4ba
parentcc534f0c7102f39454edec0c2cd938bff056819e (diff)
downloadgnu-guix-da90f337b31d53d3dc293a83e069984c70cde2ad.tar
gnu-guix-da90f337b31d53d3dc293a83e069984c70cde2ad.tar.gz
gnu: Update python-django-filter to 1.1.0.
* gnu/packages/django.scm (python-django-filter)[version]: Update from 0.14.0 to 1.1.0. [source]: Update sha256 hash. [native-inputs]: Add python-djangorestframework and python-django-crispy-forms as native inputs, as they are used in the test suite.
-rw-r--r--gnu/packages/django.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 2768ae2af1..24d096bc0f 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -182,13 +182,13 @@ useful tools for testing Django applications and projects.")
(define-public python-django-filter
(package
(name "python-django-filter")
- (version "0.14.0")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "django-filter" version))
(sha256
(base32
- "0f78hmk8c903zwfzlsiw7ivgag81ymmb5hi73rzxbhnlg2v0l3fx"))))
+ "0slpfqfhnjrzlrb6vmswyhrzn01p84s16j2x1xib35gg4fxg23pc"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -198,6 +198,8 @@ useful tools for testing Django applications and projects.")
(zero? (system* "python" "runtests.py")))))))
(native-inputs
`(("python-django" ,python-django)
+ ("python-djangorestframework" ,python-djangorestframework)
+ ("python-django-crispy-forms", python-django-crispy-forms)
("python-mock" ,python-mock)))
(home-page "https://django-filter.readthedocs.io/en/latest/")
(synopsis "Reusable Django application to filter querysets dynamically")