summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-04 13:23:15 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-09 18:18:48 +0000
commitcc534f0c7102f39454edec0c2cd938bff056819e (patch)
tree3666f313fe5c5d262bbe8d53c6f3baf9af79f951
parentd5f56e9089aa743e12f54163a879c17eab48380e (diff)
downloadgnu-guix-cc534f0c7102f39454edec0c2cd938bff056819e.tar
gnu-guix-cc534f0c7102f39454edec0c2cd938bff056819e.tar.gz
gnu: Add python-django-crispy-forms.
* gnu/packages/django.scm (python-django-crispy-forms): New variable.
-rw-r--r--gnu/packages/django.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index f944d25b60..2768ae2af1 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -779,3 +779,28 @@ Django projects, which allows association of a number of tags with any
"The Django REST framework is for building Web APIs with Django. It
provides features like a web browseable API and authentication policies.")
(license license:bsd-2)))
+
+(define-public python-django-crispy-forms
+ (package
+ (name "python-django-crispy-forms")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-crispy-forms" version))
+ (sha256
+ (base32
+ "16s05jx86jmimlvnwpq73kl0mqw1v9lryc8zi61a9qwl25krm6mj"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page
+ "http://github.com/maraujop/django-crispy-forms")
+ (synopsis "Tool to control Django forms without custom templates")
+ (description
+ "@code{django-crispy-forms} lets you easily build, customize and reuse
+forms using your favorite CSS framework, without writing template code.")
+ (license license:expat)))